Jan
01

DBSlayer is an awesome lightweight database abstraction layer that is used under high-load websites. While nothing I am working on is necessarily high-load I am going to be using DBSlayer to work on a few projects using Node.js (Which deserves a post of its own.) Installing the DBSlayer requires the following other libraries must be installed first:

  • the Apache Portable Runtime (APR) library (1.0 or above)
  • the Apache Portable Runtime Utility (APU) library (1.0 or above)
  • the MySQL 5 client libraries (5.0 or above)

While somewhat basic you may run into an issue with this if you already have XAMPP installed on your machine.  XAMPP keeps all of these files located in the /xamppfiles/bin/ folder. Therefore you need to modify your ./configure line when installing DBSlayer.

Not rocket science but it took me a few minutes to debug. Hopefully this saves someone some time.

About Jim Walker:

Jim Walker is a software engineer and entrepreneur in Northeastern Pennsylvania.

Find all posts by Jim | Visit Website

You can leave a response, or trackback from your own site.